Monatsarchive: September 2012

Great resources on solving OSGi „Uses“ constraint violations

I recently had the „famous“ „uses“ constraint violation when building my OSGI application with PDE Build. It was complaining about: Package uses conflict: Import-Package: javax.mail; version=“1.4.1″ The following resources have helped me locating the root cause and understanding the problem: … Weiterlesen

Veröffentlicht unter Software-Development | 2 Kommentare